import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)^.+\\bCurrent: ([\\d.]+).+\\bLatest: ([\\d.]+).*$";
final String string = "GAMADV-XTD3 6.07.31 - https://github.com/taers232c/GAMADV-XTD3 - pyinstaller\n"
+ "Ross Scroggs <ross.scroggs@gmail.com>\n"
+ "Python 3.9.7 64-bit final\n"
+ "Windows 10 10.0.18363 SP0 Multiprocessor Free AMD64\n"
+ "Path: C:\\GAMADV-XTD3\n"
+ "Config File: C:\\GAMConfig\\gam.cfg, Section: DEFAULT, customer_id: C047encoi, domain: sonos.com \n"
+ "Version Check:\n"
+ " Current: 6.07.31\n"
+ " Latest: 6.07.31\n";
final String subst = "$1 $2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}