using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/api/ping(?:(?:/[^/\s]+)*\.\S+|$)";
string input = @"/api/ping.json
/api/ping
/api/ping/xxx/sss.json
/api/ping.xml
/api/ping/.json
/api/pingpong
/api/ping_pong
/api/ping-pong";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}