// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)/api/ping(?:(?:/[^/\s]+)*\.\S+|$)").unwrap();
let string = "/api/ping.json
/api/ping
/api/ping/xxx/sss.json
/api/ping.xml
/api/ping/.json
/api/pingpong
/api/ping_pong
/api/ping-pong";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}