package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)/api/ping(?:(?:/[^/\s]+)*\.\S+|$)`)
var str = `/api/ping.json
/api/ping
/api/ping/xxx/sss.json
/api/ping.xml
/api/ping/.json
/api/pingpong
/api/ping_pong
/api/ping-pong`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}