$re = '~/api/ping(?:(?:/[^/\s]+)*\.\S+|$)~m';
$str = '/api/ping.json
/api/ping
/api/ping/xxx/sss.json
/api/ping.xml
/api/ping/.json
/api/pingpong
/api/ping_pong
/api/ping-pong';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);