using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\[img(?:\].+\[\/img\]|=.+\])$";
string input = @"[img]https://example.com/image.jpg[/img]
[img=https://example.com/image.jpg]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}