package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\[img(?:\].+\[\/img\]|=.+\])$`)
var str = `[img]https://example.com/image.jpg[/img]
[img=https://example.com/image.jpg]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}