re = /^\[img(?:\].+\[\/img\]|=.+\])$/m
str = '[img]https://example.com/image.jpg[/img]
[img=https://example.com/image.jpg]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end