$re = '/^\[img(?:\].+\[\/img\]|=.+\])$/m';
$str = '[img]https://example.com/image.jpg[/img]
[img=https://example.com/image.jpg]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);