using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?<.*?<(hhDate)>(\d+-\d+-\d+).*$";
string input = @"<abcdefghkdadajsdkdjg><hhDate>2019-12-31 <dklajdlajdkjasd>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}