$re = '/^.*?<.*?<(hhDate)>(\d+-\d+-\d+).*$/m';
$str = '<abcdefghkdadajsdkdjg><hhDate>2019-12-31 <dklajdlajdkjasd>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);