re = /^.*?<.*?<(hhDate)>(\d+-\d+-\d+).*$/m
str = '<abcdefghkdadajsdkdjg><hhDate>2019-12-31 <dklajdlajdkjasd>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end