import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\d\\s]+(?=-)|[^\\d\\s.]+(?!\\d)";
final String string = "123A.478\n"
+ "123.48\n"
+ "123AX\n\n"
+ "--123.46\n"
+ "123A-.46\n"
+ "-123--.46\n"
+ "A-123-.46";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}