$re = '/^[^\d\s]+(?=-)|[^\d\s.]+(?!\d)/m';
$str = '123A.478
123.48
123AX
--123.46
123A-.46
-123--.46
A-123-.46';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;