re = /^[^\d\s]+(?=-)|[^\d\s.]+(?!\d)/m
str = '123A.478
123.48
123AX
--123.46
123A-.46
-123--.46
A-123-.46'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result