import re
regex = re.compile(r"^[^\d\s]+(?=-)|[^\d\s.]+(?!\d)", flags=re.MULTILINE)
test_str = ("123A.478\n"
"123.48\n"
"123AX\n\n"
"--123.46\n"
"123A-.46\n"
"-123--.46\n"
"A-123-.46")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)