package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[-#+]*(?:[0-9]+[-\s]*)?\(?[0-9]{1,4}\)?(?:[-\s./]*[0-9])*`)
var str = `can i make a call to +21231313
can i make a call to -21231313
can i make a call to 21231313
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}