$re = '/[-#+]*(?:[0-9]+[-\s]*)?\(?[0-9]{1,4}\)?(?:[-\s./]*[0-9])*/m';
$str = 'can i make a call to +21231313
can i make a call to -21231313
can i make a call to 21231313
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);