re = /[-#+]*(?:[0-9]+[-\s]*)?\(?[0-9]{1,4}\)?(?:[-\s.\/]*[0-9])*/m
str = 'can i make a call to +21231313
can i make a call to -21231313
can i make a call to 21231313
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end