#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)<logicalIdentifier>(?<Identifier>.+?)(?=<).+?<status>(?<Status>.+?)(?=<)"
Local $sString = " <logicalIdentifier>1234-YYYMMDD</logicalIdentifier>" & @CRLF & _
" <status>Accepted</status>" & @CRLF & _
" <logicalIdentifier>2345-YYYMMDD</logicalIdentifier>" & @CRLF & _
" <status>Accepted</status>" & @CRLF & _
" <logicalIdentifier>3456-YYYMMDD</logicalIdentifier>" & @CRLF & _
" <status>Accepted</status>" & @CRLF & _
" <logicalIdentifier>4567-YYYMMDD</logicalIdentifier>" & @CRLF & _
" <status>Accepted</status>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")