const regex = /(?s)<logicalIdentifier>(?<Identifier>.+?)(?=<).+?<status>(?<Status>.+?)(?=<)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)<logicalIdentifier>(?<Identifier>.+?)(?=<).+?<status>(?<Status>.+?)(?=<)', 'gm')
const str = ` <logicalIdentifier>1234-YYYMMDD</logicalIdentifier>
<status>Accepted</status>
<logicalIdentifier>2345-YYYMMDD</logicalIdentifier>
<status>Accepted</status>
<logicalIdentifier>3456-YYYMMDD</logicalIdentifier>
<status>Accepted</status>
<logicalIdentifier>4567-YYYMMDD</logicalIdentifier>
<status>Accepted</status>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}