using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)<logicalIdentifier>(?<Identifier>.+?)(?=<).+?<status>(?<Status>.+?)(?=<)";
string input = @" <logicalIdentifier>1234-YYYMMDD</logicalIdentifier>
<status>Accepted</status>
<logicalIdentifier>2345-YYYMMDD</logicalIdentifier>
<status>Accepted</status>
<logicalIdentifier>3456-YYYMMDD</logicalIdentifier>
<status>Accepted</status>
<logicalIdentifier>4567-YYYMMDD</logicalIdentifier>
<status>Accepted</status>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}