using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""channelRequestId\"":\""(?<channelRequestId>[^\""]*)";
string input = @"parameterValue={""executingDetails"":{""executingxxxNumber"":xx,""executingxxxxNumber"":xxx},""requestorData"":{""requestorIDs"":{""serviceProductID"":9,
""channelRequestId"":""12345678-1234-xxxx-xxxx-abcdeffxxxx"",""variousChannelTypeCode"":9},""requestData"":{""referenceNumber"":000000,""customerRequestTimestamp"":""2017-07-24 14:37:39""}},""xxxxData"":{""xxxxxxNumberxxxx"":""xxx"",""xxxToken"":""9dc2b23f-ea4a-4632-8b57-f37eaebab64c""},""debitTransactionData"":{""requestAmount"":1210.0,""currencyTypeCode"":1}}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}