// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\"channelRequestId\":\"(?<channelRequestId>[^\"]*)"#).unwrap();
let string = "parameterValue={\"executingDetails\":{\"executingxxxNumber\":xx,\"executingxxxxNumber\":xxx},\"requestorData\":{\"requestorIDs\":{\"serviceProductID\":9,
\"channelRequestId\":\"12345678-1234-xxxx-xxxx-abcdeffxxxx\",\"variousChannelTypeCode\":9},\"requestData\":{\"referenceNumber\":000000,\"customerRequestTimestamp\":\"2017-07-24 14:37:39\"}},\"xxxxData\":{\"xxxxxxNumberxxxx\":\"xxx\",\"xxxToken\":\"9dc2b23f-ea4a-4632-8b57-f37eaebab64c\"},\"debitTransactionData\":{\"requestAmount\":1210.0,\"currencyTypeCode\":1}}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}