import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"channelRequestId\\\":\\\"(?<channelRequestId>[^\\\"]*)";
final String string = "parameterValue={\"executingDetails\":{\"executingxxxNumber\":xx,\"executingxxxxNumber\":xxx},\"requestorData\":{\"requestorIDs\":{\"serviceProductID\":9,\n"
+ "\"channelRequestId\":\"12345678-1234-xxxx-xxxx-abcdeffxxxx\",\"variousChannelTypeCode\":9},\"requestData\":{\"referenceNumber\":000000,\"customerRequestTimestamp\":\"2017-07-24 14:37:39\"}},\"xxxxData\":{\"xxxxxxNumberxxxx\":\"xxx\",\"xxxToken\":\"9dc2b23f-ea4a-4632-8b57-f37eaebab64c\"},\"debitTransactionData\":{\"requestAmount\":1210.0,\"currencyTypeCode\":1}}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}