# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"channelRequestId\":\"(?<channelRequestId>[^\"]*)"
test_str = ("parameterValue={\"executingDetails\":{\"executingxxxNumber\":xx,\"executingxxxxNumber\":xxx},\"requestorData\":{\"requestorIDs\":{\"serviceProductID\":9,\n"
"\"channelRequestId\":\"12345678-1234-xxxx-xxxx-abcdeffxxxx\",\"variousChannelTypeCode\":9},\"requestData\":{\"referenceNumber\":000000,\"customerRequestTimestamp\":\"2017-07-24 14:37:39\"}},\"xxxxData\":{\"xxxxxxNumberxxxx\":\"xxx\",\"xxxToken\":\"9dc2b23f-ea4a-4632-8b57-f37eaebab64c\"},\"debitTransactionData\":{\"requestAmount\":1210.0,\"currencyTypeCode\":1}}")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.