#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^0?$|^(?:0?[1-9]|1[012]?)(?:-(?:(?:0$|0?[1-9]|[12]\d|3[01])(?:-\d{0,4})?)?)?$"
Local $sString = "" & @CRLF & _
"30-0" & @CRLF & _
"30-01-" & @CRLF & _
"30-01-2016" & @CRLF & _
"30-01-20161" & @CRLF & _
"" & @CRLF & _
"1-30" & @CRLF & _
"01-30-" & @CRLF & _
"01-30-2016" & @CRLF & _
"01-30-20161" & @CRLF & _
"" & @CRLF & _
"2016-" & @CRLF & _
"2016-01-" & @CRLF & _
"2016-01-30" & @CRLF & _
"2016-01-301"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")