package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^0?$|^(?:0?[1-9]|1[012]?)(?:-(?:(?:0$|0?[1-9]|[12]\d|3[01])(?:-\d{0,4})?)?)?$`)
var str = `
30-0
30-01-
30-01-2016
30-01-20161
1-30
01-30-
01-30-2016
01-30-20161
2016-
2016-01-
2016-01-30
2016-01-301`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}