const regex = /^0?$|^(?:0?[1-9]|1[012]?)(?:-(?:(?:0$|0?[1-9]|[12]\d|3[01])(?:-\d{0,4})?)?)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^0?$|^(?:0?[1-9]|1[012]?)(?:-(?:(?:0$|0?[1-9]|[12]\\d|3[01])(?:-\\d{0,4})?)?)?$', 'gm')
const str = `
30-0
30-01-
30-01-2016
30-01-20161
1-30
01-30-
01-30-2016
01-30-20161
2016-
2016-01-
2016-01-30
2016-01-301`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}