$re = '/^0?$|^(?:0?[1-9]|1[012]?)(?:-(?:(?:0$|0?[1-9]|[12]\d|3[01])(?:-\d{0,4})?)?)?$/m';
$str = '
30-0
30-01-
30-01-2016
30-01-20161
1-30
01-30-
01-30-2016
01-30-20161
2016-
2016-01-
2016-01-30
2016-01-301';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);