using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^.*?)?(\[[0-9]+:[0-9]+:[0-9]+:[0-9]+\] )?("".+?"") ([0-9]+) ([0-9-]+)";
string input = @"141.243.1.172 [29:23:53:25] ""GET /Software.html HTTP/1.0"" 200 233
[29:23:53:25] ""GET /Software.html HTTP/1.0"" 200 233
""GET /Software.html HTTP/1.0"" 200 233";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}