// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(^.*?)?(\[[0-9]+:[0-9]+:[0-9]+:[0-9]+\] )?(".+?") ([0-9]+) ([0-9-]+)"#).unwrap();
let string = "141.243.1.172 [29:23:53:25] \"GET /Software.html HTTP/1.0\" 200 233
[29:23:53:25] \"GET /Software.html HTTP/1.0\" 200 233
\"GET /Software.html HTTP/1.0\" 200 233";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}