package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^.*?)?(\[[0-9]+:[0-9]+:[0-9]+:[0-9]+\] )?(".+?") ([0-9]+) ([0-9-]+)`)
var str = `141.243.1.172 [29:23:53:25] "GET /Software.html HTTP/1.0" 200 233
[29:23:53:25] "GET /Software.html HTTP/1.0" 200 233
"GET /Software.html HTTP/1.0" 200 233`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}