re = /(^.*?)?(\[[0-9]+:[0-9]+:[0-9]+:[0-9]+\] )?(".+?") ([0-9]+) ([0-9-]+)/m
str = '141.243.1.172 [29:23:53:25] "GET /Software.html HTTP/1.0" 200 233
[29:23:53:25] "GET /Software.html HTTP/1.0" 200 233
"GET /Software.html HTTP/1.0" 200 233'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end