using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Task \d - (\w+)\n";
string input = @"Task 1 - complete
Task 2 - ongoing
Task 3 - planned
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}