$re = '/Task \d - (\w+)\n/m';
$str = 'Task 1 - complete
Task 2 - ongoing
Task 3 - planned
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);