re = /Task \d - (\w+)\n/m
str = 'Task 1 - complete
Task 2 - ongoing
Task 3 - planned
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end