using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\(?\d{3}\)?[ .-]\d{3}[ .-]\d{4}$";
string input = @"(222) 222.2222
(222).222.2222
(222) 222-2222
(222)-222-2222
222.222.2222
222-222-2222
222 222-2222
222 222.2222";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}