re = /^\(?\d{3}\)?[ .-]\d{3}[ .-]\d{4}$/m
str = '(222) 222.2222
(222).222.2222
(222) 222-2222
(222)-222-2222
222.222.2222
222-222-2222
222 222-2222
222 222.2222'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end