import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\(?\\d{3}\\)?[ .-]\\d{3}[ .-]\\d{4}$";
final String string = "(222) 222.2222\n"
+ "(222).222.2222\n"
+ "(222) 222-2222\n"
+ "(222)-222-2222\n"
+ "222.222.2222\n"
+ "222-222-2222\n"
+ "222 222-2222\n"
+ "222 222.2222";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}