package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\(?\d{3}\)?[ .-]\d{3}[ .-]\d{4}$`)
var str = `(222) 222.2222
(222).222.2222
(222) 222-2222
(222)-222-2222
222.222.2222
222-222-2222
222 222-2222
222 222.2222`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}