#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)((\d+(?:\.\d+)?).*\(Scored\))"
Local $sString = "2.10 Add nodev Option to Removable Media Partitions" & @CRLF & _
"45 FDFDF" & @CRLF & _
" (Scored)" & @CRLF & _
"Profile Description:Set nodev on removable media to prevent character and block special devices that are present , on the removable media from being treated as device files."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")