import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\d+(?:\\.\\d+)?).*\\(Scored\\))";
final String string = "2.10 Add nodev Option to Removable Media Partitions\n"
+ "45 FDFDF\n"
+ " (Scored)\n"
+ "Profile Description:Set nodev on removable media to prevent character and block special devices that are present , on the removable media from being treated as device files.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}