using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<\$test\.)\d{6}(>\h;;CODE2)";
string input = @"<$test.123456> ;;CODE1
<$test.123456> ;;CODE2
<$test.123456> ;;CODE3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}