re = /(<\$test\.)\d{6}(>\h;;CODE2)/m
str = '<$test.123456> ;;CODE1
<$test.123456> ;;CODE2
<$test.123456> ;;CODE3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end