$re = '/(<\$test\.)\d{6}(>\h;;CODE2)/m';
$str = '<$test.123456> ;;CODE1
<$test.123456> ;;CODE2
<$test.123456> ;;CODE3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);