package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<\$test\.)\d{6}(>\h;;CODE2)`)
var str = `<$test.123456> ;;CODE1
<$test.123456> ;;CODE2
<$test.123456> ;;CODE3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}