#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0\.\,]*$"
Local $sString = "0.000,00" & @CRLF & _
"0.000.000.00" & @CRLF & _
"0" & @CRLF & _
"10" & @CRLF & _
"dafsd" & @CRLF & _
"0,3" & @CRLF & _
"1.0" & @CRLF & _
"0,00004" & @CRLF & _
"1.000" & @CRLF & _
"000000000000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")