re = /^[0\.\,]*$/m
str = '0.000,00
0.000.000.00
0
10
dafsd
0,3
1.0
0,00004
1.000
000000000000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end