import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0\\.\\,]*$";
final String string = "0.000,00\n"
+ "0.000.000.00\n"
+ "0\n"
+ "10\n"
+ "dafsd\n"
+ "0,3\n"
+ "1.0\n"
+ "0,00004\n"
+ "1.000\n"
+ "000000000000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}